summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Singleton <matt@xcolour.net>2018-03-07 17:40:15 -0500
committerMatt Singleton <matt@xcolour.net>2018-03-07 17:40:15 -0500
commit8abfddf83bb42121587cf808b2ea90a3148ed1be (patch)
treed2ddf84f6fe485fc3a21c6d1beab2c65e7fa097e /setup.py
parent10fce3985f651832bf1d3809e54841e6e149dd1c (diff)
get travis to build the whl and push it to github?
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 11 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3c2e35d..2feb200 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,18 @@
+import os
from setuptools import setup
+buildnum = os.environ.get('TRAVIS_BUILD_NUMBER')
+if buildnum is None:
+ version = '0.dev0'
+else:
+ version = buildnum
+gitrev = os.environ.get('TRAVIS_COMMIT')
+if gitrev is not None:
+ version = '{}+{}'.format(version, gitrev)
+
setup(
name="unbiased",
- version="5",
+ version=version,
packages=['unbiased', 'unbiased.sources'],
package_data={
'unbiased': [