summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Singleton <matt@xcolour.net>2018-03-07 19:51:09 -0500
committerMatt Singleton <matt@xcolour.net>2018-03-07 19:51:09 -0500
commitd517561e80cec0c249ae8467f991f602019ed196 (patch)
tree7cb13b165979a0dcc60a73194f082f8f470f54ac /setup.py
parentf0b2136c463f2effda5aa8adbab5ae5454334f22 (diff)
save the git commit in the description
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 06dad3d..625bc00 100644
--- a/setup.py
+++ b/setup.py
@@ -5,14 +5,17 @@ buildnum = os.environ.get('TRAVIS_BUILD_NUMBER')
if buildnum is None:
version = '0.dev0'
else:
- version = buildnum[:7]
+ version = buildnum
gitrev = os.environ.get('TRAVIS_COMMIT')
-if gitrev is not None:
- version = '{}-{}'.format(version, gitrev)
+if gitrev is None:
+ description = ''
+else:
+ description = gitrev
setup(
name="unbiased",
version=version,
+ description=description,
packages=['unbiased', 'unbiased.sources'],
package_data={
'unbiased': [